Widora-BIT16CY工作在路由模式下,DHCP地址不对



  • 设置Widora-BIT16CY工作在路由模式下,连接上对应的无线网之后,分配的IP地址时192.168.43.,不是192.168.1.,因此无法打开192.168.1.1,也不能通过scp传输文件了,版主这个问题有遇到过吗,


  • administrators

    @ekko1 http://wiki.widora.cn/netmode
    不同模式,从哪个方向去访问板子可能有细微区别,具体看看这个表格
    0_1522837788556_屏幕快照 2018-04-04 下午6.29.31.png


  • administrators

    @Ekko1 修改dhcp里:

    /etc/config/dhcp
    config dnsmasq
            option domainneeded '1'
            option boguspriv '1'
            option filterwin2k '0'
            option localise_queries '1'
            option rebind_protection '1'
    

    rebind 这一行改为0,重启试试



  • 在设置到router模式后,br-lan的地址为空,不是192.168.1.1,这个正常吗,这种情况下,连接到widora-EA78(wifi名字)之后,ping不通92.168.1.1,显示,PING传输失败,常见故障,还有我把dhcp对应的位改成1之后还是不行


  • administrators

    @ekko1 空是不正常的。
    贴一下有问题的/etc/config/network 和wireless文件。
    以及局域网路由器的网关IP地址



  • /etc/config/network 内容:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fdb9:fd00:7f3a::/48'

    config interface 'lan'
    option force_link '1'
    option macaddr '0c:ef:af:d1:17:8d'
    option type 'bridge'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '...1'
    option ifname 'eth0'
    option proto 'dhcp'

    config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 6t'



  • wireless 文件内容:

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'CN'
    option hwmode '11bgn'
    option htmode 'HT20'
    option channel 'auto'
    option disabled '0'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option ifname 'ra0'
    option ssid 'Widora-EA78'
    option encryption 'psk2'
    option key 'QWERTYUI'
    option hidden '0'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option ifname 'apcli0'
    option encryption 'psk'
    option ssid 'Xiaomi_201'
    option key 'yangjiale20051028'
    option disabled '0'
    option network 'lan'

    局域网路由器的IP网关地址192.168.31.1